Register
Login
I got a chance to play a bit of EotU again this weekend since it had been a long time since I completed the campaign. The levels were fun as always, but the narration wouldn't start for 2.1. I've tried playing it on different difficulties or selecting different units, but there is no voice, even though the voice is on max volume. The rest of the sound, like effects, works great, and it works on all the other levels, so I'm not sure what the problem is.

Also, for free play mode, isn't the narrator supposed to say "The queen is in danger" and things like that? If he is not supposed to say things like that, my mistake, but if he is supposed to, he doesn't.

This is all on mac.
Posted from my Zombie bunker in northeast Ohio.

  • Mike

  • Colony
  • *
    Administrator
    *
    Global Moderator
    *
    Community Manager
Thanks for the report. I'll pass it on to Matt.

No problem. There is another major bug I encountered, and I think it has already been reported, but I'll mention it anyway. During the formicarium challenge 1, enemy ants, starting off with one of the waves of Formica ereptor, became stuck at my nest entrance, and all of my ants wouldn't move.

I think there was one or a few bugged enemies that were stuck inside the ground of my nest holes, and because they were stuck in the ground when my army aggroed on them, my army got stuck. I couldn't place a new pheromone or delete the pheromone to get them to move, but when I disabled attack, they probably deaggroed and they would move. Eventually, there was a single formica ereptor enemy visibly stuck inside the ground in my nest entrance. I disabled attack and put the pheromone right on top of him, and then enabled my attack and one of my ants was close enough to kill it. After it died, my army moved normally again. This kept happening with the waves that followed.

In the final wave, all of the enemies except for a couple enemy ants, a single beetle larva, and a single adult beetle entered my nest. The rest was completely stuck at the top, right next to my nest entrance. I was able to kill them by simply placing my pheromone at the top, but after my ants attacked the enemies in their range, they got stuck too. To clear out the area I had to disable attack, move my army, and then enable attack when they were right on top of the enemies in order to kill them.

Note that the narration and win cutscene were working perfectly. After the cutscene, the food dropped in as normal, and my ants gathered food from the dead insects, except for one. There seemed to be a dead adult devil's coach horse beetle in the middle of my three nest holes that was apparently being harvested from by two ants. Three of my ants, two soldiers, and one worker, were stuck, inside one of my nest holes. I suspected they were the ones who were supposed to be gathering meat, but they wouldn't move at all, and they wouldn't move when I disabled and enabled gather food and attack enemies. Therefore there was a carcass that was not harvestable from, and it would probably remain there until I quit the game.

I'm not sure where these glitches came from, but maybe something was changed when free play mode was introduced, because in free play sometimes when reloading a new save, your ants when you tell them to go to the surface, will get stuck in the nest holes. They'll visibly be above ground if you toggle health bars, but they'll be in the area beneath the nest entrance. To solve this the player must place the pheromone back underground, and then back to the surface. After doing this once or twice they'll begin moving from underground to the surface at normal speed. This bug won't happen again until you quit and reload the save.
« Last Edit: August 28, 2018, 01:30:16 AM by Buffalo981 »
Posted from my Zombie bunker in northeast Ohio.

I have a few similar glitches to report about free play mode.

First, a minor glitch, but on wave 5, some wolf spiders spawned, and while they movement speed and attack was fine, their legs wouldn't play their walking animation.

The main bugs I'm here about are similar to my post above. On wave 9, insects began to get stuck by my nest entrance. On wave 9, only four wood ants got stuck, and it wasn't a big deal. Something I noted is that when the bugs got stuck in my formicarium, my army would get stuck too and wouldn't respond to pheromones unless their attack was disabled. This didn't seem to be the case here.

On wave 10, it became a much bigger problem. All of the ants that spawned entered the nest normally (maybe one or two ants got stuck that I missed). All of the 10-20 small tiger beetles that spawned got stuck, all of the small/medium wolf spiders that spawned got stuck, and the uber devil's coach horse beetle got stuck.

This glitch, which happens around at wave 9-10 of free play mode and formicarium challenge 1 (I haven't seen whether it affects formicarium challenge 2, but I'm guessing it does), sort of ruins the gameplay. In free play mode, it actually becomes easier to beat the wave. In waves 1-8 of that playthrough for me, I felt excited about what the next wave might be, and that kept me playing. I was anticipating the uber creature entering my nest with a wave of enemies at wave 10, but it ended up getting stuck with the majority of the other enemies and was easy to kill. The glitch in both free play and formicarium challenge splits up your enemies (about 60% stay on top, 40% enter), and making the wave a lot less intimidating and fun.

I definitely want to help you guys solve this bug, so if there is any information you need about my settings or if you need help trying to recreate it, I'm glad to help.
Posted from my Zombie bunker in northeast Ohio.

Same here.

As you can see. One Ant and one critter are stuck inside the entrance. And there is a dead dhc-larvae too that can not be harvested.